Back to overview
Degraded
Dashboard & API Degraded
May 23 at 09:02am PDT
Affected services
Dashboard
API
Resolved
May 23 at 02:07pm PDT
Resolved. All services operational.
Affected services
Created
May 23 at 09:02am PDT
Unusually high database load has led to temporary downtime and degraded performance on our application. We're working to fix this as soon as possible.
Affected services